Bug Fixed: Secure Browsing on Crew Manager Sites Gives Mixed Browser Lock Results

If you find a bug, please report it in this forum.
Post Reply
User avatar
admin
Site Admin
Posts: 170
Joined: Fri Dec 28, 2018 11:51 am
Location: Portsmouth, RI
Contact:

Bug Fixed: Secure Browsing on Crew Manager Sites Gives Mixed Browser Lock Results

Post by admin » Wed Feb 12, 2020 11:24 am

Jason Black from the Baltic 52 JULES reported the inability to get an encrypted (SSL) connection so the web browser shows a lock symbol on all pages. Some initial troubleshooting for identifying the source of the problem includes:

1. Sites setup without SSL enabled - this will be enabled for all sites
2. Some external image content is referenced as http rather than https - these links will be updated
3. Internal program links use http rather than https protocol - these will be updated in the software
4. The Wind Widget in the sidebar is in an iframe and always breaks the lock symbol when the sidebar is displayed - this needs to be researched for a solution
Crew Manager Administrator
Image

User avatar
admin
Site Admin
Posts: 170
Joined: Fri Dec 28, 2018 11:51 am
Location: Portsmouth, RI
Contact:

Re: Partial Fix: Secure Browsing on Crew Manager Sites Gives Mixed Browser Lock Results

Post by admin » Thu Feb 13, 2020 1:57 am

Site security and secure browsing has been enhanced. A status report on the problems identified is below.

1. Sites setup without SSL enabled - Complete - SSL enabled for all sites
2. Some external image content is referenced as http rather than https - Complete - image links updated to https for all sites
3. Internal program links use http rather than https protocol - Complete - links updated to https for all sites
4. The Wind Widget in the sidebar is in an iframe and always breaks the lock symbol when the sidebar is displayed - this needs to be researched for a solution Not yet complete
Crew Manager Administrator
Image

User avatar
admin
Site Admin
Posts: 170
Joined: Fri Dec 28, 2018 11:51 am
Location: Portsmouth, RI
Contact:

Re: Bug Fixed: Secure Browsing on Crew Manager Sites Gives Mixed Browser Lock Results

Post by admin » Mon Feb 17, 2020 11:56 pm

Success! The Wind Widget in the sidebar has been updated to Sailflow. All sites have been updated as of 15 February and were tested to get the browser lock symbol. You may need to clear your browser cache to delete the old pictures or may get an "unsecure site" message.
Crew Manager Administrator
Image

Post Reply